Big problem with Artisteer 4 and IE8


Author Message
Greg

Posted: 10/14/2012 Quote message   

Hi, got a few problems with Artisteer 4 final release and IE8. I know, I hate IE just as much, but so many people still use it.

Gradients, shadows and rounded corners no longer seem to work. Whether they be background, menu bar or button gradients. Rounded buttons or rounded page borders stopped working as well as shadows.

These all used to work in 3.1, but are now completely ignored in IE8, and IE7.

I know in Artisteer 3.1 these were exported as images and from what I see now it looks as if Artisteer 4 tries to make use of CSS code to generate these on the fly in IE...but they don't work!


 
Steve

Posted: 10/14/2012 Quote message   

Hiya Greg,

.... and they will never ever work in ie7 or ie8, Artisteer 4 makes use of CSS3 and html5 which is simply not supported in ie7 or ie8.

I try and design so that things do not look so bad in ie7 and ie8 for my own sites; but for client sites I still use Artisteer 3.1.

Hope this clears things a bit for you and a lot of people complaining about the same thing. Artisteer 4 is geared for modern compliant browsers using html5 and CSS3, like Chrome and Firefox nd ie9 and ie10, but the fact is that nearly 30% of the world still use ie7 and ie8. For those just design using Artisteer 3.1. OR design around this issue using Artisteer 4 - some flat designs (without gradients and shades) are not that bad if the correct colors are used for menus etc.

Hope this helps you somewhat :-) I know it's not much consolation, but that's how things stand right now !

 
Greg

Posted: 10/14/2012 Quote message   

Thanks Steve

Ok that sucks. Was hoping for some backward compatibility for older browsers...well at least IE7 and IE8 that could load alternate style as far as gradients and corners are concerned . No one cares about anything older than that anymore.

So looks like I'll be stuck using Artisteer 3.1 for the next 6 years until all the PC's running old IE versions are long dead ;-)
 
Steve

Posted: 10/14/2012 Quote message   

LOL

I've been reading all over this forum about this problem, its not Artisteers problem really ... if you think about it .... they are making compliant software and try and ease the pain a bit for ie7 and ie8, but the issue is with ie7 and ie8 ...

So backward compatibility if you don't want to get your hands dirty with JavaScript and CSS is version 3.1 ..

 
Jef

Posted: 10/19/2012 Quote message   

I want Buy ver 4 , when is the full version is produse?
please answer friends.
 
iahnn

Posted: 10/25/2012 Quote message   

And the best solution is build a version that you can choose the compatibility... or compatible with all browsers :-D
 
endre

Posted: 11/4/2012 Quote message   

Quote Greg:

Hi, got a few problems with Artisteer 4 final release and IE8. I know, I hate IE just as much, but so many people still use it.

Gradients, shadows and rounded corners no longer seem to work. Whether they be background, menu bar or button gradients. Rounded buttons or rounded page borders stopped working as well as shadows.

These all used to work in 3.1, but are now completely ignored in IE8, and IE7.

I know in Artisteer 3.1 these were exported as images and from what I see now it looks as if Artisteer 4 tries to make use of CSS code to generate these on the fly in IE...but they don't work!




Any Artisteer version released should be web browser backward compatible at least 1 version ; in this case IE8! :-<
 
Sig Weber

Posted: 11/6/2012 Quote message   

Quote Dave B:

I think due to the technology shift it just isn't possible without some heavy extra code.


Actually, it took me only a few minutes to tweak some lines of an exported HTML template to make it work in any non-HTML5 capable Webrowser like Firefox 3.6, Camino or even IE7/8. The crux is the HTML5 semantic elements Artisteer v4 ads for header/nav/article/footer. Once those are replaced with DIV tags and the corresponding CSS has been tweaked it works almost flawlessly (the responsive design has some issues, though) in any older browser.

Quote Dave B:

Do the best you can to make IE8 look OK but keep in mind the future is not IE8 technology and they are better off spending their time working on a forward thinking software.


100% agreed.

Quote Dave B:

Besides with the bugs in this version I would MUCH rather have them get that fixed instead of trying to do some backward compatibility fixes that won't matter in a year anyway.


Well, IMHO it'll take about up to five years but that's just a guess...

Quote Dave B:

Believe me, I was super mad and against the decision myself but now don't care at all. Just get this thing working so I can make some websites with it without having to trouble shoot so much.


100% agreed. I've already opened plenty of support request with issues/bug on v4 which hinder me on switching from v3 to v4.

 
adhikar

Posted: 11/6/2012 Quote message   

helo guys , how do i buy Artisteer ? thanks
 
Dave B

Posted: 11/6/2012 Quote message   

Quote Sig Weber:

Well, IMHO it'll take about up to five years but that's just a guess...


Man I hope not. Although I just keep finding more everyday. Tons of little things that are just super annoying.
 
David

Posted: 11/6/2012 Quote message   

Quote Dave B:


Actually, it took me only a few minutes to tweak some lines of an exported HTML template to make it work in any non-HTML5 capable Webrowser like Firefox 3.6, Camino or even IE7/8. The crux is the HTML5 semantic elements Artisteer v4 ads for header/nav/article/footer. Once those are replaced with DIV tags and the corresponding CSS has been tweaked it works almost flawlessly (the responsive design has some issues, though) in any older browser.



Do you have any quick suggestions on what needs tweaking? I tried to create this theme using $ but in retrospec I should have used 3 and forgotten about the responsive aspects seeing I've disabled that support.

I'm hoping to go live soon but seeing some very weird things in IE8 on the footer of the main page.

http://testingsite.roddiscomms,com

Any suggestions would be most welcome.
 
Garry

Posted: 11/8/2012 Quote message   

Yes, you'll be able to save after activation. You'll get a license key on purchase.
 
Adhikar

Posted: 11/9/2012 Quote message   

thanks Garry
 
Pierre

Posted: 11/14/2012 Quote message   

I'm moving back to v3.1 as well. It was so much better than v4.0. Basically if it's not backwards compatible then it is of no use to man or beast. Artisteer should have kept this issue in mind with version 4 but alas they did not. This will remain an issue for years to come until people stop using the older browsers. So Artisterr need to put v4.0 on the back burner and concentrate on making v3.1 even better.
 
Careswho

Posted: 11/21/2012 Quote message   

Hah.. I was going to have sleepless night if I hadn't come across this thread!
My whole right sidebar in my page with a blog-layout is gone in ie8! It is one single page with the side bad shown after main content..

I went straight for Artisteer4, so never know about v3.1 though had downloaded it and tried to work on it because of better compatibility but I found 4 to be better!

Thanks all..
 
Garry

Posted: 11/21/2012 Quote message   

@ Careswho

These type of issues are caused by incorrect HTML markup like missing divs, I'll suggest you to try validating your webpage on W3C Validator.
 
Jon

Posted: 2/4/2013 Quote message   

Gradiant menus look great in Firefox. Only solid color in Safari and IE.
I cannot go back to Artisteer 3.1 as I am exporting to Joomla 2.5 (not available in Artisteer 3.1).

I need a workaround directly in CSS file to load an image with the appropriate gradiant if it can't be done with artisteer.

This is vital to my client's design. Too many hours already spent trying to make this menu cross-browser compatible.
 
Tommy

Posted: 2/5/2013 Quote message   

Quote Jon:

Gradiant menus look great in Firefox. Only solid color in Safari and IE.
I cannot go back to Artisteer 3.1 as I am exporting to Joomla 2.5 (not available in Artisteer 3.1).

I need a workaround directly in CSS file to load an image with the appropriate gradiant if it can't be done with artisteer.

This is vital to my client's design. Too many hours already spent trying to make this menu cross-browser compatible.

Joomla 1.7 templates will work in Joomla 2.5. You can make Joomla 1.7 templates in 3.1
 
oldman

Posted: 3/20/2013 Quote message   

Artisteer 3.1 => OK
Artisteer 4 => not OK for me
because my user client pc use IE 6.28 1x,xxx pc
 
jacksmith

Posted: 6/14/2013 Quote message   

At last the "data sheet" http://www.artisteer.com/?p=download_datasheet_pdf

says:
Internet Explorer 6+, Firefox 2+, Opera 9+, Safari 1+, Chrome 1+...


...but that seems to be not up to date.....
 
Boo

Posted: 6/19/2013 Quote message   

Hi

So what it the resolution to the problem cant there be a tweak in the template files that can sort the issue?
 
SPABO

Posted: 9/30/2013 Quote message   

Quote :
So what it the resolution to the problem cant there be a tweak in the template files that can sort the issue?


Any news on this, is there a workable "workaround" to have V4 at least working in IE8?



Bear in mind, app 11.8% of all users are using IE and app 4,7% of the total amount of usres still use IE8

2013 IE 10 IE 9 IE 8 IE 7 IE 6 Total
August 3.60% 2.80% 4.70% 0.60% 0.10% 11.80%




2013	IE 10	IE 9	IE 8	IE 7	IE 6	Total August	3.60%	2.80%	4.70%	0.60%	0.10%	11.80%
Pls advise as soon as possible.
 
Eileen
Artisteer Team

Posted: 10/23/2013 Quote message   

to SPABO:
have you tried the latest Artisteer 4.2 version? - http://www.artisteer.com/?p=news
In case you'll get the problem with it as well, I would recommend that you contact Artisteer support or describe the issue here and provide a link to your page.
 
ducktape

Posted: 10/30/2013 Quote message   

Eileen,
Your proposed solution is not an option to consider for anyone who does not wish to require online connection with version 4.2 of Artisteer.

I am still with 4.1 and until the online connection is removed I have no intention of renewing.

Regards,

Ducktape

==========================

Quote Eileen:

to SPABO:
have you tried the latest Artisteer 4.2 version? - http://www.artisteer.com/?p=news
In case you'll get the problem with it as well, I would recommend that you contact Artisteer support or describe the issue here and provide a link to your page.

 
Francy

Posted: 1/27/2014 Quote message   

Hi I had the same problem with Artisteer 4. (woordpress themes) The problem is the code HTML5. I added this javascript in the header.php
before the </head>

<script type="text/javascript">
document.createElement('header');
document.createElement('footer');
document.createElement('section');
document.createElement('aside');
document.createElement('nav');
document.createElement('article');
</script>
 


Artisteer is not affiliated with or endorsed by Joomla!™ or Drupal™ or WordPress™ Projects.

Other services from Artisteer Team: Themler, BillionPhotos, BillionThemes and Createer is coming soon.

Copyright © 2008-2014 by Artisteer, Ltd