Top menu format not showing


Author Message
Mike Hersee

Posted: 8/23/2018
Quote message 

I have a template I previously created in Artisteer 3 that I imported into Artisteer 4.3. The top menu has some nicely formatted tabs. I've exported the menu into Joomla 3.8, but for some reason the menu is displayed in a simple vertical format instead of the horizontal tabs. When I go into 'advanced' within the module, in the list of available module stylesI can't find a format in the list that works as the right layout. I've tried all the ones listed, and some did have some effect, but not the desired one.

For some reason the image option isn't working so I can't load the images I just saved to illustrate the problem. Any help would be appreciated though.

Mike
 
Mike Hersee

Posted: 8/25/2018
Quote message 

It's ok, I've fixed it. It was because for some reason in Modules: Menu > Advanced > Menu class suffix there was '-nav'. Removing it caused the menu to display properly.
 
Gabriel

Posted: 8/30/2018
Quote message 

Just wanted to tell you about a possible correction in «-nav» mode. But it's great that you sorted it out yourself. I though for a long time already do not use templates, but sometimes I take necessary parts from them. It's easier for me to work with the finished one, and the missing if there is not enough knowledge is easier to supplement the web development company, like https://rubygarage.org/services/web-development . Usually such a double process allows you to keep the site both up to date and fully working.