PHP 7.x not compatible with Artisteer

Author Message

Posted: 4/29/2017
Quote message 

After installing joomla 3.7 I will take php version 7.1, but after that the website gets an error front end seems below:

0 - Using $this when not in object context.

How can it be solved?

Posted: 6/15/2017
Quote message 


Here is manual solution also:

open template folder on the server >> html/modules.php file
find the following lines:
function modChrome_artnostyle($module, &$params, &$attribs)
function modChrome_artblock($module, &$params, &$attribs)
function modChrome_artvmenu($module, &$params, &$attribs)
function modChrome_artarticle($module, &$params, &$attribs)

and remove & character, e.g.:
function modChrome_artnostyle($module, $params, $attribs)

This should help.

Thank you,

Posted: 9/4/2018
Quote message 

I have an Artisteer template that runs OK under PHP 7.0 and Joomla 3.8.12.

I've tried upgrading my server to PHP 7.1 but get the "0 - Using $this when not in object context" error message and have to drop the site back to 7.0.

The modules.php doesn't have any "&" characters in the lines mentioned.

Any other changes that might need to be made?

Posted: 9/6/2018
Quote message 

Found it. Error messaging showed it to be another plug-in.
David van Dijck

Posted: 9/7/2018
Quote message 


Same problem here.

Colin could you say which plug-in maybe??

I removed all & characters and it doesn't work with php 7.1 or 7.2


Posted: 10/10/2018
Quote message 

"No need to learn Photoshop, CSS, HTML or other technologies
Fun and easy to use!" says the Artisteer sales blurb on their site, yet you are expected to hand-edit this code in some obscure template directory to make sites work with php7.1 (I understand previous versions of php are no longer supported).
If you're going to carry on selling it surely a fix is required.

Posted: 10/11/2018
Quote message 

Having said that, the fix above posted by Laura/Olivia appears to have worked on the only site I've so far tried it on, tedious though it is.

I looked at the modules.php file from the most recent site I've done in Artisteer , probably last quarter of 2017, and that still had the $ characters so I'm not sure any Artisteer update has taken place (unlikely I would have thought), unless anyone knows different? Haven't had time to test further.

Lars Nielsen

Posted: 11/23/2018
Quote message 

After upgrading PHP from 5,6 to 7,2 im getting this error:
Warning: count(): Parameter must be an array or an object that implements Countable in /customers/4/a/6/xxxxxxx/httpd.www/libraries/cms/application/cms.php on line 464
Lars Nielsen

Posted: 11/24/2018
Quote message 

I have also seen sites where the top menu has gone missing since the php upgrade. How is this possible to fix?

Posted: 12/1/2018
Quote message 

I've the same problem. All the issues are fixed, but the website is not running after the updates to PHP 7.1 or 7.2. Its only work on PHP 7.0. But end of this year it's outdated!.
How we can fix this?
Harald Nordli

Posted: 7/16/2019
Quote message 

Thank you for your tip, Olivia. You are great. :-) :-{}