Update to joomla 3.7 error


Author Message
Andreas

Posted: 4/27/2017
Quote message 

Hallo all.

I updated my joomla to 3.7 and my responsive template creates the following error.
Notice: Undefined offset: 1 in /...../templates/responsive/library/Artx/Content/Item.php on line 68

it's the original code created by artisteer ..

private function _buildIconJ3($text, $file, $alt, $wrapUpTooltip = false) {

$app = JFactory::getApplication();
$src = JURI::root(true) . '/templates/' . $app->getTemplate();
preg_match('/<a[^>]*>(.*?)<\/a>/', $text, $matches);
$linkContent = $matches[1];
$newLinkContent = '<img src="' . $src . '/images/system/' . $file . '" alt="' . $alt . '" />';
$text = str_replace($linkContent, $newLinkContent, $text);
if ($wrapUpTooltip) {
preg_match('/title="([^"]*)"/', $linkContent, $matches);
$tooltipText = $matches[1];
$tooltipText = preg_replace('/<strong>(.*?)<\/strong><br \/>/', '$1 :: ', $tooltipText);
$text = '<span class="hasTip" title="' . $tooltipText . '">' . $text . '</span>';


somebody can help me on this?

thanks





 
Marco Roebersen

Posted: 5/1/2017
Quote message 

I've got the same problem.

Please somebody tell us what to do..

Thanks :)
Marco

Quote Andreas:

Hallo all.

I updated my joomla to 3.7 and my responsive template creates the following error.
Notice: Undefined offset: 1 in /...../templates/responsive/library/Artx/Content/Item.php on line 68

it's the original code created by artisteer ..

private function _buildIconJ3($text, $file, $alt, $wrapUpTooltip = false) {

$app = JFactory::getApplication();
$src = JURI::root(true) . '/templates/' . $app->getTemplate();
preg_match('/<a[^>]*>(.*?)<\/a>/', $text, $matches);
$linkContent = $matches[1];
$newLinkContent = '<img src="' . $src . '/images/system/' . $file . '" alt="' . $alt . '" />';
$text = str_replace($linkContent, $newLinkContent, $text);
if ($wrapUpTooltip) {
preg_match('/title="([^"]*)"/', $linkContent, $matches);
$tooltipText = $matches[1];
$tooltipText = preg_replace('/<strong>(.*?)<\/strong><br \/>/', '$1 :: ', $tooltipText);
$text = '<span class="hasTip" title="' . $tooltipText . '">' . $text . '</span>';


somebody can help me on this?

thanks







 
Pierre

Posted: 5/1/2017
Quote message 

I was afraid this would be the issue with Artisteer and J7.

Time to find another template designer is about the best advice I have.

 
Alexandre

Posted: 5/2/2017
Quote message 

Hi,

Don't worry, it is not an error but only a PHP notice.
You have to connect in your Joomla administrator
1) System - Global configuration
2) Server tab
3) Error reporting ==> None
4) Save
All will be ok

Best regards

Alexandre from France
 
Rasta Man

Posted: 5/3/2017
Quote message 

Quote Alexandre:

Hi,

Don't worry, it is not an error but only a PHP notice.
You have to connect in your Joomla administrator
1) System - Global configuration
2) Server tab
3) Error reporting ==> None
4) Save
All will be ok

Best regards

Alexandre from France


Great! Thank you so much :-)!
 
Joe

Posted: 5/4/2017
Quote message 

Thanks for the heads up with the Joomla 3.7 update. The current version of Artisteer is coming up on 2 years old, that's a long time for this type of software. The designs it makes are look dated and I haven't been impressed with Themler enough to justify using. As for me and our team we're moving to Gridbox 2.0 (at balbooa.com) on Joomla, it just came out today. On Wordpress we're using Divi 3.0.

Artisteer had a good run, but nothing lasts forever.