Compatiblity with Wordpress 4.7, i think no


Author Message
adespont@outlook.com

Posted: 12/14/2016
Quote message 

I have errors and warnings on my artisteer page on wordpress 4.7,
With debug on login is no more functional.

has anyone same problem?
:-(
 
andrew

Posted: 2/9/2017
Quote message 

Hier die Korrektur:
library/widgets.php
Zeile: 128
Alt:
function VMenuWidget() {
$widget_ops = array('classname' => 'vmenu', 'description' => __('Use this widget to add one of your custom menus as a widget.', THEME_NS));
parent::WP_Widget(false, __('Vertical Menu', THEME_NS), $widget_ops);
}

Ersatz:
function __construct() {
$widget_ops = array('classname' => 'vmenu', 'description' => __('Use this widget to add one of your custom menus as a widget.', THEME_NS));
parent::__construct(false, __('Vertical Menu', THEME_NS), $widget_ops);
}

Zeile: 211
Alt:
function LoginWidget() {
$widget_ops = array('classname' => 'login', 'description' => __('Login form', THEME_NS));
$this->WP_Widget(false, __('Login', THEME_NS), $widget_ops);
}

Ersatz:
function __construct() {
$widget_ops = array('classname' => 'login', 'description' => __('Login form', THEME_NS));
parent::__construct(false, __('Login', THEME_NS), $widget_ops);
}
Es gibt noch ein weiterer Fehler beim Login:
Konnte diesen noch nicht korrigieren.