Nav menu shifting


Author Message
LeeW

Posted: 12/9/2012
Quote message 

On a page refresh or nav button click, my horizontal menu shifts to the left of the screen, then moves back to the correct position.

This happens in IE8, IE9 and Firefox. In Chrome, the entire page jumps up then settles back in correct position.

It occurs regardless of responsive/non-responsive and when the menu is set within the sheet or full length.

Any tips?
 
speedyp

Posted: 12/9/2012
Quote message 

I've noticed this as well, except the whole header, logo & horiz nav shifts to the left then "jumps" back into place.

It's really annoying & one of the reasons I'm sticking with V3 for now :-/
 
LeeW

Posted: 12/9/2012
Quote message 

I'm not so sure this is a bug with V4. I activated each theme that came with my wordpress install and they all do it. I tried a second install to a different directory and got the same thing.

Today the problem seems to have cleared up in IE and Firefox. Again, I tried it on all themes, even the ones not built with artisteer and they all work fine.

I am beginning to think maybe the issue was on my host's side all along.
 
speedyp

Posted: 12/9/2012
Quote message 

Quote Zach:

How long does the shift take? ... Does your site have lots of large images that are messing with your load time?


I built 2 sites, 1 with art3 & 1 with v4. V3 version doesn't do this at all. V4 it jumps. This happens very quickly, but enough to notice / distract. Happens on all pages regardless of content & images etc.

Sounds like the op's problem has sorted itself out...

 
Zach

Posted: 12/11/2012
Quote message 

Looks like you may be right!
 
John

Posted: 12/13/2012
Quote message 

Just noticed this same thing happening with my Art V4 sites on Joomla 2.5.8 but only seems a problem for me on Firefox on a Mac OS X (windows 7 with Firefox is not doing this).

I hope someone smarter than I am finds a reason and solution for this (unless of course it's a browser bug?).
 
Heidi

Posted: 1/26/2013
Quote message 

I have the same problem in IE9, but not in Firefox. Does anybody know if this is fixed in v.4.1?:-/
 
Abland

Posted: 1/26/2013
Quote message 

Hi,

It's the way the header is laid out that they do that jump. I tried a few things, including displaying last (close but still not that great for loading appearance), but setting widths had the best results. Let's say the sheet it 1000px in width. Set a max width on the nav:
/* use art-nav if no art-nav-inner in theme */

.art-nav-inner {
margin: 0 auto;
max-width: 1000px;
}

In header.php add an id to the body tag, art-custom (or your choice).
</head>

<body <?php body_class(); ?> id="art-custom">

Then use the id to set the width on the shapes container:
#art-custom .art-shapes {

position: relative;
display: block;
width: 1000px;
height: 100%;
margin: 0 auto;
overflow: visible !important;
}

Then adjust each shape object rules using the custom page id:
#art-custom .art-object0 {

left: 20% !important;
right: auto;
margin-left: 0px !important;
}

It's a little bit of work but the results were good.
 
Garulfo

Posted: 2/25/2013
Quote message 

Same problem here: http://www.givingtree.fr (Abland's solution didn't work)

Client is really annoyed :-< - so am I.

Need a fix asap!
 
Tatjana

Posted: 6/10/2014
Quote message 

Quote Abland:

Hi,

It's the way the header is laid out that they do that jump. I tried a few things, including displaying last (close but still not that great for loading appearance), but setting widths had the best results. Let's say the sheet it 1000px in width. Set a max width on the nav:
/* use art-nav if no art-nav-inner in theme */

.art-nav-inner {
margin: 0 auto;
max-width: 1000px;
}

In header.php add an id to the body tag, art-custom (or your choice).
</head>

<body <?php body_class(); ?> id="art-custom">

Then use the id to set the width on the shapes container:
#art-custom .art-shapes {

position: relative;
display: block;
width: 1000px;
height: 100%;
margin: 0 auto;
overflow: visible !important;
}

Then adjust each shape object rules using the custom page id:
#art-custom .art-object0 {

left: 20% !important;
right: auto;
margin-left: 0px !important;
}

It's a little bit of work but the results were good.


Thank you very much! It solved my problem. My artisteer wordpress sites were jumping left and then right in chrome and in ie10. Now it looks fine.

I have added also

/* Keep Vertical Scrollbar */
html {
overflow-y: scroll;}
/* End Keep Vertical Scrollbar */

 
Elvira
Artisteer Team

Posted: 6/10/2014
Quote message 

The issue with shifting usually occurs with the following combination of settings:
Header outside sheet + Header length = Page width

If to change either the position or the length, the shifting will disappear. Once the settings is changed, it's almost always possible to arrange Header to the same look.

If you have any questions, you can always contact Artisteer Support and we'll help you do that.

Best regards,
Elvira
 
David

Posted: 7/9/2014
Quote message 

Quote Elvira:

The issue with shifting usually occurs with the following combination of settings:
Header outside sheet + Header length = Page width

If to change either the position or the length, the shifting will disappear. Once the settings is changed, it's almost always possible to arrange Header to the same look.

If you have any questions, you can always contact Artisteer Support and we'll help you do that.

Best regards,
Elvira



Hello Elvira,
I have the same problem in all browsers, but I want to keep page width and header position as

]Header outside sheet + Header length = Page width

Is there another solution, please?
 
Barry G

Posted: 2/3/2016
Quote message 

I realise that I am a bit late to the game here, but I am getting this behaviour on my Wordpress site using Artisteer v4.2. Rather annoyingly, when I was using this template on a Joomla site, I had no issues.

Apart from the rather manual solution proposed by Abland, is there a simpler way to solve this problem? Is it fixed in v4.3?
 
Anna-Lena

Posted: 1/3/2017
Quote message 

Dear support!
Almost 4 years later and the bug has not been fixed yet.
Can you PLEASE fix it? Or is it unfixable?


 
Denia

Posted: 2/9/2018
Quote message 

The same problem here :-< http://caledonianway.es