Functions Error


Author Message
Anthony

Posted: 7/19/2011 Quote message   

Just upgraded to 1.7 and am now getting:

Fatal error: Cannot access protected property ContentViewArticle::$user in /home/bphillip/public_html/templates/bpmusic_v1/functions.php on line 561

I tried the other functions.php modifications I found in another thread. But that did not work.
 
liv

Posted: 7/19/2011 Quote message   

Same here. Artisteer template is not working for joomla 1.7.
 
Tommy

Posted: 7/19/2011 Quote message   

This is the error i am getting sikce updating.

Fatal error: Call to a member function getMessageQueue() on a non-object in /home1/ourtimed/public_html/templates/otd_white/functions.php on line 165
 
Sandy

Posted: 7/19/2011 Quote message   

I have similar errors on 2 different sites.
Looks like there's something changed from 1.7RC to 1.7 that causes an incompatibility with Artisteer. :(
 
Anthony

Posted: 7/19/2011 Quote message   

What I find lame is this. I got this answer from Artisteer support:

"Hello

We plan to release Joomla 1.7 compatibility release in the next few days."

All I can say is, WTF! Joomla 1.7 RC has been out for months. How could they let this happen?

IF YOU USE ARTISTEER DO NOT UPGRADE TO 1.7 YET!


 
Caitlin

Posted: 7/19/2011 Quote message   

Hello,

We have just announced an update, please visit:

http://www.artisteer.com/?p=news

Best regards,

Caitlin N
Extensoft, Inc. / Artisteer
Artisteer - The Automated Web Designer
http://www.artisteer.com
Twitter: http://twitter.com/ArtisteerTeam
 
Topaz

Posted: 7/20/2011 Quote message   

Quote Caitlin:

Hello,

We have just announced an update, please visit:

http://www.artisteer.com/?p=news

Best regards,

Caitlin N
Extensoft, Inc. / Artisteer
Artisteer - The Automated Web Designer
http://www.artisteer.com
Twitter: http://twitter.com/ArtisteerTeam

Why did you not test on the Joomla 1.7.0 RC1 ? That was what it was released for. Also see http://docs.joomla.org/Potential_backward_compatibility_issues_in_Joomla_1.7_and_Joomla_Platform_11.1

 
jrgweb.net

Posted: 7/20/2011 Quote message   

Quote Anthony:

What I find lame is this. I got this answer from Artisteer support:

"Hello

We plan to release Joomla 1.7 compatibility release in the next few days."

All I can say is, WTF! Joomla 1.7 RC has been out for months. How could they let this happen?

IF YOU USE ARTISTEER DO NOT UPGRADE TO 1.7 YET!





Anthony, I don't have a problem with joomla 1.7 and the latest Artisteer release.
http://j17.jrgweb.net/index.php/joomla17

I already upgraded and don't have issues. Go figure.

Check your server or php or something.
 
mschuble

Posted: 7/21/2011 Quote message   

Right after upgrading to Joomla 1.7 my website would only depict the following:

Fatal error: Cannot access protected property ContentViewArticle::$user in /home/content/m/s/c/mschuble75/html/templates/mschublemarketinganddesigntemplatev4/functions.php on line 462

Tried various upgrades and combed the Joomla forum to no avail. Thanks to this forum for leading me in the right direction. on the 20th I upgraded my Artisteer to version 3 thinking that could be the problem, but it didn't work, turns out I did it a day too soon, because there is now a newer Artisteer 3 version and replacing the previous Version 3 with this one and then re-saving my template with this new version, and then uploading it into Joomla and making the new default worked!!!! :-D

So bottom line is, if you're experiencing the same Fatal Error I outlined above, check to see if the version of Artsteer you have is Artisteer.3.0.0.41778. If not, get it.
 
Chris

Posted: 7/21/2011 Quote message   

I confirm that templates created with Artisteer 3.0.0.41778 for Windows work with Joomla! 1.7.0
 
ERROR

Posted: 8/4/2011 Quote message   

KEEP HAVING ERROR ERROR ERROR
 
jrgweb

Posted: 8/4/2011 Quote message   

OK, send me your artx file. I'll export it then test it on my server.

jrgweb@gmail.com
 
Garry

Posted: 8/4/2011 Quote message   

Artisteer 3.0.0.41778 created templates are working just fine on my side in Joomla 1.7

For Joomla 1.7 compatibility "Make Sure":

1- You are running PHP5 on your hosting server.
2- You are using Artisteer 3.0.0.41778 version.
3- Have read following instructions: http://www.artisteer.com/?p=help_joomla


 
mverros

Posted: 1/23/2012 Quote message   

i try to save my joomla template and i receive this message:

<Error

Enable to save the file.
Please contact product support>

any idea, what happend?

Thanks a lot..
 
Garry

Posted: 1/23/2012 Quote message   

@ mverros

You need to purchase an Artisteer license for fixing this issue: http://www.artisteer.com/?p=purchase
 
Maria

Posted: 3/16/2012 Quote message   

I am getting this on joomla 1.7 and 2.5

Fatal error: Cannot access protected property ContentViewArticle::$user in /homepages/xx/xxxxxxxxxxxx/htdocs/domain.com/templates/nameoftemplate/functions.php on line 878

I do not have the artisteer file, and thus wonder if somebody can help me rewrite the php to fix this error?

And I noticed a strange thing: when I upgraded from 1.6 I got this error, but when I put the same template on a clean joomla 2.5 install, everything is fine. How come?

If the error cannot get fixed, would it be possible to transfer just the content from the 1.6 install to the 2.5 install?
 
Artisteer is not affiliated with or endorsed by Joomla!™ or Drupal™ or WordPress™ Projects.

Copyright © 2008-2014 by Artisteer, Ltd