New version 2.5.0.29814 Bug Found


  Page 1 of 2 Next Last 
Author Message
webmaster@webz-llc.com

Posted: 8/4/2010 Quote message   

Drop down menu ignores order set in wordpress and is alphabetical only can't change it with page order
 
Kelley Rao

Posted: 8/4/2010 Quote message   

First, I'm not the author of this post...maybe for Christmas we'll get a real forum software for this devoted group! But I think I understand the reason for the poster doing this so I will say "thanks!"

Regarding above, using the release from today, I have no problem arranging the navigation order however I like.

Kelley Rao, Webeze
www.web-eze.com
 
Kelley Rao

Posted: 8/4/2010 Quote message   

Oops...I guess it's just a concidence that we have similar company names. Excuse my faux pas.

-Kel
 
Chuck Wilson

Posted: 8/4/2010 Quote message   

Drop down menu navigation? I've created 2 new themes with this new version and both do the same thing pages show up in admin in right order but then are alphabetical on the website
Quote Kelley Rao:

First, I'm not the author of this post...maybe for Christmas we'll get a real forum software for this devoted group! But I think I understand the reason for the poster doing this so I will say "thanks!"

Regarding above, using the release from today, I have no problem arranging the navigation order however I like.

Kelley Rao, Webeze
www.web-eze.com


 
Daniel

Posted: 8/4/2010 Quote message   

There's more than a couple of bugs still in this version. I can't speak to the first one but here's what I've found so far:

1. Widgetized footer is not styled properly. All of the widgets output is centered and since we can't style it in Artisteer it doesn't look quite right.

2. There is a CSS issue with IE when you show the front page (index.php) or an archive view for that matter with post_thumbnails attached.


 
Abland

Posted: 8/4/2010 Quote message   

Hi, Daniel,

I'm reporting this to support also, but for point 1. in style.css find:

.art-footer,
.art-footer p,
.art-footer div
.art-footer li
{
color: #52594F; /* your colour might differ */
text-align: center;
}

and change this to:

.art-footer,
.art-footer p,
.art-footer div
{
color: #52594F;
text-align: center;
}

.art-footer li
{
text-align: left;
}
 
Kelley Rao

Posted: 8/4/2010 Quote message   

@Chuck

Are you using the Menu tool within WP 3.0? Create your menu there and then you can move the pages around as you like. Poke around in that Menu area -- it will come to you fairly intuitively once you spend a few minutes there.

-Kel
 
Abland

Posted: 8/4/2010 Quote message   

Hi, Chuck,

Also, are you referring to the Horizontal Menu, or Vertical?

In the WordPress admin: Appearance > Menus I created two custom menus. For ease I called them Custom Horizontal and Custom Vertical, then Saved.

Then under "Theme Locations" I associated the Primary Menu with Custom Horizontal and Secondary Menu with Custom Vertical, then Saved.

The vetrtical menu can also be replaced with the Navigation Menu widget.
 
Chuck Wilson

Posted: 8/4/2010 Quote message   

Horizontal menu
but it is actually thye drop down menu's that don't follow the order set in wordpress
 
Abland

Posted: 8/4/2010 Quote message   

Hi, Chuck,

My submenus work so it must do with associating your custom menu with the Primary Menu under Theme Locations.
 
Chuck Wilson

Posted: 8/5/2010 Quote message   

Response to my support request

Chuck,

Thank you for pointing this out.
In fact, the issue is reproducible and we have forwarded it to our developers.


Best regards,

Caitlin N
Extensoft, Inc.
/ Artisteer
Artisteer - The Automated Web Designer
http://www.artisteer.com
Twitter: http://twitter.com/ArtisteerTeam

 
Benn

Posted: 8/5/2010 Quote message   

I'm experiencing the same thing :-@
I downloaded the latest version - updated my theme - uploaded to the server
and the horizontal & the vertical submenus - Do Not Follow the assigned order

waitin on a patch.....
 
Kelley Rao

Posted: 8/5/2010 Quote message   

Artisteer acknowledged bug report of missing artx/icon (thumnail) and replied:

Thank you for pointing this out.

We will fix the issue for the next Artisteer update.

Caitlin N
Extensoft, Inc.
 
Kelley Rao

Posted: 8/5/2010 Quote message   

@ Chuck and Benn

I created a brand new (test) site using both vertical and horizontal menus with sub menus. I am able to add sub menus to each of these navigation areas and control the order in which they are displayed.

Does this pertain only to existing themes that you've updated? I havent' tried that yet but will do so later today as time permits.

Kelley Rao, Webeze
www.web-eze.com
 
Richard

Posted: 8/5/2010 Quote message   

I'm experiencing a problem as well, I had my menu order working fine until I updated the template today and now no matter what I do they stay alphabetical and not the order in which I choose to have them, this for horizontal menu with no sub menus yet although I did do a test and it won't let me sort those as well to the way I want them.
 
Andy

Posted: 8/5/2010 Quote message   

@Richard
I have the same problem with horizontal navigation menu order.

I see develoepers has aknowledge that and will update version.But if you find the solution post it here.

Thanks.
 
andiho

Posted: 8/6/2010 Quote message   

Same Problem - Menu (horizontal and vertical) is always in alphabetical order.

@Kelly
Menu-Tool in WP 3 is great, but its not as powerfull as the menu-tool in artisteer...


 
Abland

Posted: 8/6/2010 Quote message   

Hi,

In the admin Appearance > Menu, are you associating your primary and secondary menus with your custom menus?

I had the same results as others have mentioned until I created Horizontal Menu and Vertical Menu as my custom menus, then saved them as Primary and Secondary under Theme Locations. Everything worked fine after that.
 
Abland

Posted: 8/6/2010 Quote message   

I should mention that not of my pages have any order assigned to them. I do that through the Appearance > Menu drag and drop.
 
Richard

Posted: 8/6/2010 Quote message   

Quote Abland:

I should mention that not of my pages have any order assigned to them. I do that through the Appearance > Menu drag and drop.

You are right Abland that does work, first time I tried it for some reason it did not work, which I feel it was firefox caching that was the culprit showing me nothing has changed, this time I tried it with Opera, lol!

 
DivaVocals

Posted: 8/7/2010 Quote message   

Quote Kelley Rao:

Does this pertain only to existing themes that you've updated? I havent' tried that yet but will do so later today as time permits.
It does seem to only affect converted templates (createdin a previous version of Artisteer and updated in ver 2.5).. However, that still makes this a bug..

I shouldn't have to recreate every recent Artisteer generated theme I've created to "workaround" this bug. But it seems that's what many of us will have to do, and that kinda sucks..
:-)
 
DivaVocals

Posted: 8/7/2010 Quote message   

Wow!! This worked.. Goodness.. I was pulling my hair out over this!!!!

Quote Abland:

Hi,

In the admin Appearance > Menu, are you associating your primary and secondary menus with your custom menus?

I had the same results as others have mentioned until I created Horizontal Menu and Vertical Menu as my custom menus, then saved them as Primary and Secondary under Theme Locations. Everything worked fine after that.

:-D
 
Shawn

Posted: 8/7/2010 Quote message   

:-<

I want my 3 hours back of searching online, edited php, etc. before applying Abland's fix.
 
Benn

Posted: 8/9/2010 Quote message   

:-)
Abland's fix worked for me and my themes generated on previous versions

Thank you Abland!! 8-)
 
Karen

Posted: 8/9/2010 Quote message   

What happens if you're not on the latest version of Wordpress?

I don't have a menu option under appearance.
This has been driving me crazy and I downloaded other plugins to try to fix it too. Other themes work fine but not the one I've updated with artisteer latest release.

Regards,
Karen
 
Andreas

Posted: 8/9/2010 Quote message   

I have the same problem and I'm sorry to say that Ablands fix doesen't work for me.
I got the right menu Order now, but the menu design is broken (I built a tab-structure) and submenues are not visible. :(
 
Richard

Posted: 8/10/2010 Quote message   

Quote Andreas:

I have the same problem and I'm sorry to say that Ablands fix doesen't work for me.
I got the right menu Order now, but the menu design is broken (I built a tab-structure) and submenues are not visible. :(

It works, under appearance>menus, when you add it to the menu place it under the page where you want the sub menu to be and make sure you indent it, drag it to the right a bit.
 
Abland

Posted: 8/10/2010 Quote message   

Quote "Andreas":
but the menu design is broken (I built a tab-structure) and submenues are not visible.


Hi, Andreas,

I'm assuming vertical menu - are you using the "Custom Menu" widget? To keep your original format you would use the "Navigation Menu" widget:

Source: Custom Menu
Select Menu: the menu you created

If that's not it, can you post a link?
 
SWMedia

Posted: 8/11/2010 Quote message   

Am having same issue. Do we have ETA on this bug and when it will be fixed....
 
Scott

Posted: 8/11/2010 Quote message   

This vertical navigation menu bug is a real bummer...
I did apply Ablands fix, but it looks like crap and is simply a bullet style menu :(
I'm going to try and revert back to the previous version so I can eliminate this problem...
 
  Page 1 of 2 Next Last 


Artisteer is not affiliated with or endorsed by Joomla!™ or Drupal™ or WordPress™ Projects.

Other services from Artisteer Team: stock photos, WordPress themes and Joomla templates. Createer and more are coming soon.

Copyright © 2008-2014 by Artisteer, Ltd